Авторские электронные устройства

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Авторские электронные устройства » Устройства с сайта » Устройство плавного гашения света в салоне автомобиля


Устройство плавного гашения света в салоне автомобиля

Сообщений 1 страница 30 из 55

1

Собрал данное устройство но почему-то ничего не работает, правда работает плавное гашение света при открытой двери если включить зажигание. Бузер вообще не пищит.  Пик прошил без ошибок, если поставить обратно в программатор  то с прошивкой все нормально. Или может это урезанная версия прошивки? Прошивка отсюда http://electroavto.narod.ru/mk_svet/mk_svet.rar

0

2

Нет, прошивка не урезанная. Прошивка 100% рабочая и устройство это одно из самых ранних на сайте и повторено уже уймой людей. У всех оно работает! Ищите ошибки в монтаже. Неплохо было бы сюда фотку выложить монтажа, может бы мы что нибудь и найдем. Обычно все "бяки" и вылазят из-за малозаметной ошибки.

0

3

У меня заработала сразу и первая и втарая версия прошывки,подтверждаю схема 100% рабочия

0

4

Спасибо за подсказки, у меня просто слитала прошивка с МК, проблемма решина. Устройство работает почти полностью. :O  Кроме этой функции все работает "Если закрыть дверь при включенном зажигании или включить зажигание после закрытия двери, но когда свет еще горит в течении 5 сек, то сразу происходит плавное затухание (т.е. без 5 секундной выдержки)." А точнее после включения зажигания свет плавно долго(7 сек) тухнет затем снова загорается и плавно тухнет (3 сек) снова загорается и тухнет..... ну и так до бесконечности! o.O  Подскажите пожалуйста что у меня не так. Может транзисторы стоят аналоги (ВС550) и дают такие глюки? %-) А может я не туда подаю провод который на замок зажигания? Я на этот провод подаю +12 при включенном зажигании, причем на нем +12 постоянно а не только при старте двигателя. Может не правильно подключил поправьте пожалуйста.

Отредактировано Руслан (22 Фев 2012 19:00:35)

0

5

Руслан,

Руслан написал(а):

Я на этот провод подаю +12 при включенном зажигании, причем на нем +12 постоянно а не только при старте двигателя.

Собственно-это провод,который идёт к замку зажигания на тот контакт,на котором появлется напряжение когда включаем то самое зажигание,то есть-не когда старт двигателя,а когда включается панель приборов.Проще говоря-когда зажигание выключено до упора-на этом проводе ничего не должно быть.

Руслан написал(а):

Может транзисторы стоят аналоги (ВС550) и дают такие глюки?

Тоже не верно-тут можно применить любые универсальные биполярные транзисторы,лишь бы с подходящим током и напряжением.

0

6

Проблема мигания света при включенном зажигании и закрытой двери так и не решена. Подскажите хоть в какую сторону копать.

0

7

Блок питания помощнее использовать :) вобщем сначала по питанию смотреть. Слетать программа не может по определению, даже термина такого относительно PICов нет. Как писал MAMED - фото монтажа в студию. :stupor:

0

8

Блок питания на 1,5А ток потребления 0,75А, напряжение 13-16В разное ставил а результат такой-же. Фото монтажа выложу немного пожже. Использовал печатную плату из статьи.

0

9

Злюка написал(а):

Слетать программа не может по определению, даже термина такого относительно PICов нет.

А как же эта фраза из статьи "При монтаже устройства в автомобиле нужно обязательно соединить надежно вывод массы устройства с кузовом автомобиля на один из штатных заземлителей, иначе возможны сбросы микроконтроллера во время работы стартера." Или сброс и удаление программы это разные вещи? Прошу пояснить так как в контроллерах я просто чайник.

0

10

Не путайте сброс микроконтроллера и "слетание" программы. Это два совершенно разных термина. Сброс - это перезапуск программы, аналогично кнопке RESET на компе. А слетание - это физическое нарушение целостности кода (пример. Синий экран винды :)

0

11

Руслан, пожайлуста покажите фото вашей печатной платы, извините, но мы здесь не можем лечить "трипер" по телефону.....  Ещё раз прошу прощения за OFFTOP, но посудите сами, лучше один раз увидеть, чем миллион раз написать.....

0

12

Вот обещанные фотографии, собирал по печатной плате из статьи, проверял все несколько раз все правильно только вместо КТ 315Г стоят  ВС550  у них там распиловка немного отличается из за этого две ножки перекручены и одет кембрик.
Сейчас алгоритм работы такой.
- включаю питание, S1-S4 разомкнут и зажигание выключено - лампочка не горит
- замыкаю S1-S4 на клемму массы лампочка резко загорается (зажигание выключено)
- размыкаю S1-S4 раздается 1 короткий звуковой сигнал, 5 сек. лампочка горит в полный накал затем плавно тухнет, тухнет примерно за 5 сек (время свечения лампочки около 10 сек)
- включаю зажигание (подключаю провод зажигания к клемме +12 В) нечего не происходит
- выключаю зажигание резко загорается лампочка и горит постоянно
- включаю зажигание затем замыкаю S1-S4 резко загорается лампочка
- при включенном зажигании размыкаю S1-S4 раздается 3 коротких звуковых сигнала лампочка горит 5 сек. в полный накал затем плавно тухнет, тухнет примерно за 5 сек А ТУТ САМОЕ ИНТЕРЕСНОЕ!!!! затем лампочка резко загорается и плавно тухнет но намного быстрее чем в первый раз, примерно  за 5 сек. И повторяется резкое загорание и плавное тушение за 5 сек. до бесконечности.
Вот такая беда помогите пожалуйста справится с этой проблемой, а то руки уже начинают понемногу опускаться.
http://uploads.ru/t/q/6/N/q6Nxz.jpg
http://uploads.ru/t/1/g/9/1g9uH.jpg
http://uploads.ru/t/T/g/c/TgcfM.jpg
http://uploads.ru/t/4/X/I/4XIWK.jpg

0

13

Э...а.... А почему у вас 7805-я (стабилизатор) стоит наоборот????  o.O
Даже исправность PIC'а уже гарантировать нельзя.

+1

14

Злюка написал(а):

Блок питания помощнее использовать  вобщем сначала по питанию смотреть.

Злюка вы были правы на счет блока питания он оказался паскудным!!! при 0,5А напряжение падает до 9 а то и до 7 вольт!!!!
Запитал от хорошего аккумулятора и все работает как часики!!! Спасибо всем за поддержку.

Злюка написал(а):

Э...а.... А почему у вас 7805-я (стабилизатор) стоит наоборот???? 
Даже исправность PIC'а уже гарантировать нельзя.

7505 стоит правельно Вы можете убидится в етом посмотрев рисунок печатной платы.
http://uploads.ru/t/8/v/3/8v3bH.jpg

0

15

Еще раз - 7805-я стоит не правильно!!! И вообще плата расчитана наскоко я понимаю на 78L05-ю.

0

16

Руслан написал(а):

7505 стоит правельно Вы можете убидится в етом посмотрев рисунок печатной платы.

Посмотрели - убедились 100% стоит не правильно. Так что, пока ваш ПИК каким то чудом живой, срочно скачивайте даташит на 7805-ю и смотрие где у нее вход, а где выход. А потом нам чтото доказывайте. Вот из-за таких ошибок потом еще и виноваты разработчики остаются...

+1

17

По моему стаб. правильно впаян!Просто человек немного через жопу разводку платы сделал, ну в смысле того что среднюю ножку нужно выгибать. Ну и два варианта чтобы можно было впаять и эльку и в большом корпусе.
А вот поло сам стабилизатор, в любом случае лучше ставить в не эльку. Пусть будет большой запас по потреблению!

0

18

все проверил действительно стабилизатор впаян не правельно спасибо Злюка Mamed за подсказку. А pic не сгорел наверное потому что блок питания был слабый, а аккумулятор 13 вольт выдавал. Наверное pic выдерживает питание 13 вольт. А вот дома включил от блока питания 18 В и pic приказал долго жить.

0

19

ПИК не выдерживает 13 вольт, максимум 6-7 и то не всегда. ПРосто на неправильно установленной микре 7805 и хреновом БП падало напряжение до нормального рабочего или даже еще ниже,почему и были глюки. А более сильный БП убил (или добил) ПИК.

0

20

Ехал в автобусе (Volvo, Mercedes не помню) возле кабины водителя услышал сигнал закрытия всех дверей типа "тинь-дынь" , а в этой схеме так сделать можно?

0

21

У автора есть такая конструкция, на 12ф683 пике, причем нужно отдать должное звучит ничем не хуже колокольчика с корейской ( японской) машины.

Не нужно цитировать предыдущее сообщение!

0

22

Igr44 написал(а):

У автора есть такая конструкция, на 12ф683 пике, причем нужно отдать должное звучит ничем не хуже колокольчика с корейской ( японской) машины.

как называется устройство, дайте ссылку.

0

23

Тут: http://electroavto.narod.ru/chime_bell.html

0

24

Господа подскажите у меня такая проблема лампа точнее светодиодная лампа полностью не тухнет в чем может быть проблема?

0

25

htc написал(а):

Господа подскажите у меня такая проблема лампа точнее светодиодная лампа полностью не тухнет в чем может быть проблема?


Вы Уважаемый не сказали самого главного...., откуда эта схема, что за схема.... дайте ссылку, пусть специалисты посмотрят   :glasses: , а то вообще не понятно..., иди туда не знаю куда..., возьми то , не знаю что!

0

26

Вот  Ссылка

Отредактировано htc (4 Окт 2012 07:48:16)

0

27

Утечка в транзисторе скорее всего. Много причин может быть. Ну обычно самые банальные, гдето дорога коротит или еще какая бяка.

0

28

Собрал устройство заработала сразу, спасибо что выложили к новому году прошивку))
Но вот вопрос какой, а нельзя ли сделать в данном девайсе и плавный розжиг?

0

29

Нет, в этому девайсе уже ничего нового не будет. На сайте полно других гасилок, где есть плавное включение.

0

30

Может ли устройство не работать из за отсутствующего VD2. Как я понимаю он от помех?
Устройство ни при каких условиях не подавало признаков жизни. заменил КТ315 на КТ3102. при подаче питания, вспышка лампы и все. опять ни каких признаков жизни.

Вспышка появляется и при вытащенном МК. По печатке ошибок не нашел.
В программе выставленны нужная конфгурация битов?
Теперь думаю что или МК не так прошил или на какие то емкости паразитные... уже не знаю даже.

Отредактировано Andrew7041 (13 Фев 2013 18:59:15)

0


Вы здесь » Авторские электронные устройства » Устройства с сайта » Устройство плавного гашения света в салоне автомобиля


бесплатные форумы